Export not showing all glyphs

Hey guys, I hope this is the right way to get some help. I’ve been beating my head against the wall and can’t figure this out. I am working on a variable font with four masters: thin, thin italic, bold, and bold italic. When I export the font and test it in an Adobe program, all glyphs are visible in the native Glyphs palette for thin, thin italic, and bold italic, but the glyphs are not visible for bold. The variable fonts works fine, but I cannot figure out why, when bold is selected, not all of the glyphs are available – including punctuation.

Have you read this: Testing Your Fonts in Adobe Apps | Glyphs and Eliminating Font Cache Problems | Glyphs?

Georg, as always, the answer lies in the tutorials or manual. I promise I only write you fellows when I can’t find the right subject. Clearing the temp folder in the app and re-exporting worked. Thank you, again!

1 Like

Hey guys, one last question for this project, hopefully! ha ha. Okay, I have this variable font working, no errors, all seems fine. But when I test it in Adobe Illustrator or InDesign, there are a few characters that refuse to change with the variable metrics, and stick on the bold non-italic. They keep snapping back, and then the entire text sample will no longer change with the metrics (it causes an error, I think). Any advice?

Ive tried redrawing them, and that does not seem to work.

Figured it out, Unicode issue.

@GeorgSeifert Actually that was not it. Applied Unicode numbers to those glyphs, and it did not fix the issue. Then I eliminated those glyphs and exported as a test, and what happed is taht the program did the same thing to the next character over. Not sure if you’ve run into this issue before?

how do you test? Did you read this: Testing Your Fonts in Adobe Apps | Glyphs

And can you re-type the text? If you had exported the font without unicodes, it might be that Indesign added them by glyph ID and that can explain those strange shifts. Test in FontGoggles or a web browser.