Export OTF in Glyphs 2 (675)


When exporting an OTF in 2.0 I miss the option to keep production names. I would like to keep them, because I use my own tools to create the OTL tables. Apart from the names being replaced it insists on moving the space right after the .notdef, then follow with .null. CR and the rest following the order as set in the glyph order parameter (which starts with .notdef .null CR space…).

I do get the expected names and glyph order when generating from 1.4.4. But there I have to delete the kerning before exporting, otherwise it fails with a message about a ‘dist’ feature. It is a Devanagari font, and it seems Glyphs insists on generating features, even when it does not have to.


This is a instance custom parameter now.

And there is a font parameter called “DisableAllAutomaticBehaviour”. that disables the reordering (among other things, this is specially made for cases like yours).

Thank you, Georg.

DisableAllAutomaticBehaviour is not in the pop-up, but when I pasted it in the order was as expected.

I took me a while to realize that “Don’t use production names” means the same as “Use custom naming”, because in my mind “production” is linked to what I do when drawing, rather than what Glyphs does when generating a font. So I interpreted as the opposite of what it is intended for :wink:


You see nice names in Glyphs (while designing) and the production names in the (shipping) font.


In January I could not export fonts with Glyphs 1 with a Devanagari font with kerning. Now I cannot export from Glyphs 2 either without deleting the new kerning that I just added. I get "Error: “lookup name “dist1” not defined” in Feature dist in line: 287"
In Font panel I have the parameter DisableAllAutomaticBehaviour checked.
In Features everything is empty and unchecked (what is being disabled by the disabled button?)
In the Instances I tried the parameter Remove Features with dist,kern as last attempt to prevent any future that may get confused by kerning.


That means it is trying to call a lookup called dist1, which must be defined earlier in the code, e.g. in a previous feature. Perhaps there is an auto-feature that is not caught by DisableAllAutomaticBehaviour. You can take a look into the features.fea inside the font’s Temp folder, or send the .glyphs file to the support mail address if you like.

The respective feature.

I was hoping for something that stops generating the feature. But it seems clear what is going on with the generated feature. The dist feature starts with

feature dist {
lookup dist1_devanagari {
script dev2;

and ends with

} dist1_devanagari;

script deva;
lookup dist1;

} dist;

An attempt to add the dist1_devanagari lookup to both a deva and dev2 dist feature, by the wrong name.

What is a respective feature?


that is a problem with the automatic generated kern feature. Devanagari needs the kern information in a different feature but it works exactly the same so it always has to be generated. Can you send me the .glyphs file that I can have a look?
And what version do you have?

I’ll send the file.