Export .Otf option not showing up


#1

So I just finished a font and I want to export it and use it.

I usually just go to file export and select .otf but for some reason, that option isn’t showing up.

Please help.


#2

What version of Glyphs do you have?

What system language do you use?

Can you re-download the app?


#3

Should I uninstall the app and then redownload? I guess my system language is english? I have the newest version.


#4

Just delete the app and replace it with the app from the website.


#5

Okay I just did that and it didn’t change anything.


#6

Can you check the Console app if you find anything there?


#7

And where do you store the app?


#8

Sure, how do I do that?

And I don’t really put the app anywhere except in launchpad/applications?

I usually just download it and open it.


#9

So I checked a bunch of files and the .otf option isn’t showing up for any font i’ve ever made. Thanks for helping @GeorgSeifert


#10

there is a chance that glyphs is recognizing everything as a “color-font” is there a way to undo this? I had an issue with the number 5 in the font i’m currently making. I’m not sure how or why that would effect every single font file ever though.


#11

To open Console.app type that into spotlight. In the app window, type “Glyphs” in the search field in the upper right, press cmd+K. Then start Glyphs. A bunch of lines should appear in the console app. Select them all and copy paste that info an email and send it to support at this domain (without “www” and “forum”). Thanks


#12

okay just sent it over, hopefully that is everything you need.


#13

Have you tried restarting your Mac; logging into a different user (create one in System Preferences) and trying again; and fixing privileges in Repair Mode (Start the Mac with Cmd+R).


#14

so i just tried what you said and it would let me export as .otf

I didn’t try to open the original font file though I just searched .otf and opened the first font that appeared. Is there any way to fix this for my actual login?


#15

I read this three times and I don’t know what you mean. What does this have to do with opening .otf files?


#16

Sorry, I can see how that might have been confusing. When I logged in as a guest, I mean i didn’t try opening my original .glyphs file, the font i’m trying to finish up. I just opened a random font file (.otf) in glyphs and then went straight to export to see what would happen, and the export .otf option showed up fine.

I tried the exact same thing when i logged in on my real user account and the .otf option didn’t appear on export.


#17

That means it is some setting in your user. Try the steps described in this tutorial, especially deleting prefs: https://glyphsapp.com/tutorials/crashes


#18

That last one worked!! thank you soooooooooo so much! @mekkablue


#19

well it did work, and then it crashed again and not the .otf option isn’t showing up again.


#20

okay so I tried the option show cutting edge versions and that seemed to work. It seemed like I was stuck in a loop for a big where I would open the glyphs file try to export and then glyphs would crash. Thanks again for your help on this @mekkablue and @GeorgSeifert The most important thing is that the font file exported correctly and I can use it now!


UFO export issue