Export .Otf option not showing up

And where do you store the app?

Sure, how do I do that?

And I don’t really put the app anywhere except in launchpad/applications?

I usually just download it and open it.

So I checked a bunch of files and the .otf option isn’t showing up for any font i’ve ever made. Thanks for helping @GeorgSeifert

there is a chance that glyphs is recognizing everything as a “color-font” is there a way to undo this? I had an issue with the number 5 in the font i’m currently making. I’m not sure how or why that would effect every single font file ever though.

To open Console.app type that into spotlight. In the app window, type “Glyphs” in the search field in the upper right, press cmd+K. Then start Glyphs. A bunch of lines should appear in the console app. Select them all and copy paste that info an email and send it to support at this domain (without “www” and “forum”). Thanks

okay just sent it over, hopefully that is everything you need.

Have you tried restarting your Mac; logging into a different user (create one in System Preferences) and trying again; and fixing privileges in Repair Mode (Start the Mac with Cmd+R).

so i just tried what you said and it would let me export as .otf

I didn’t try to open the original font file though I just searched .otf and opened the first font that appeared. Is there any way to fix this for my actual login?

I read this three times and I don’t know what you mean. What does this have to do with opening .otf files?

Sorry, I can see how that might have been confusing. When I logged in as a guest, I mean i didn’t try opening my original .glyphs file, the font i’m trying to finish up. I just opened a random font file (.otf) in glyphs and then went straight to export to see what would happen, and the export .otf option showed up fine.

I tried the exact same thing when i logged in on my real user account and the .otf option didn’t appear on export.

That means it is some setting in your user. Try the steps described in this tutorial, especially deleting prefs: https://glyphsapp.com/tutorials/crashes

That last one worked!! thank you soooooooooo so much! @mekkablue

well it did work, and then it crashed again and not the .otf option isn’t showing up again.

okay so I tried the option show cutting edge versions and that seemed to work. It seemed like I was stuck in a loop for a big where I would open the glyphs file try to export and then glyphs would crash. Thanks again for your help on this @mekkablue and @GeorgSeifert The most important thing is that the font file exported correctly and I can use it now!

1 Like

Hi There,
i have same trouble with this. but i don’t get it to fix. i’m use mojave os.
please help

Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

I have to update this, but still not fix it

Can you send a screenshot of your export dialog?

What happens in Console.app when you open the dialog?

Can you try in a different user on your Mac? If it works there, you know it has to do with a user setting.

And you have redownloaded and reinstalled the app already, correct?