Export UFOs not working well in 2.5.2 (1153)


#1

Hi there,

Today I updated to the latest build but now I can’t export my master (or instances) to UFO. No matter what I select as active, only one master is exported (and not the selected one).
I think it was a good move to let you export instances (not only masters) as UFO, but it’s not working well.

TIA.


#2

It works fine for me. And where do you find an option to export instances?


#3

Now I see no selector to choose the masters I want to export so I assumed it would work just like the other export tabs exporting the active instances (I think this would make sense). Anyway, only a Light master is exported to UFO, nothing else. I will send you my file.

23


#4

It doesn’t show the master selection if you only have one master.


#5

But obviuosly this is not the case, Georg. I am sending you the file.


#6

The problem was that the export dialog would stick to the state it had when it was first opened. So if you export a font with only one master and then try to exhort one with more then one, it would still show the simple dialog. Restart Glyphs and it will work. I fixed it.


#7

Cool! Now it works. Beside of this, don’t you think export UFO should work as all the other export tabs, exporting instances instead of masters?