Exported TrueType font with zero width

Hi, another issue possibly regarding custom script. I am developing a Tengwar font with my custom xml, and it works just fine apart from the numeral anchor issue I mentioned earlier, and the new problem. When I exported as TrueType or web font, all glyphs with Unicode values get zero width.

What is the problem? I am using PUA for Tengwar but that doesn’t seem to be the problem as PS OT just works fine.

My guess is that there is a mistake in the XML.
Did you define them as nonspacing in your XML?
Is the XML tidy?

can you send me your GlyphData and .glyphs file?

As I said, the PostScript version is generated exactly as intended. It’s only the TT version that causes the problem.
Files being sent to Georg.

Was this ever resolved? I appear to have the same problem with an icon font created within Glyphs (no custom xml) as the PUA glyphs have zero width.

No, it hasn’t been solved yet.

I think I just fixed it.

Fantastic Georg!
In the meantime I did find that using FontSquirrel to convert the exported OTF file to the various web font formats works just fine.

I tried exporting with the new version and the problem still persists.

I just uploaded a new version that should fix the problem.

I tried it, and unfortunately it’s not fixed.

can you send me the .glyphs file?

Version 765 should fix the problem.