Exported variable font adds axis name as one of the styles

Screenshot 2021-07-12 at 19.44.23
Screenshot from Indesign’s font menu.

Choosing the “width” style selects the variable font origin style. I’d rather have just the defined instances in the style listing – how to remove this “Width” style from there?

Also, this might be related: Glyphs 3 adds “Regular” to the exported font name. This didn’t occur when the same font was exported from Glyphs 2. This question has been asked in the forum a couple of times but had dried up without solutions.

Can you send us the .glyphs file?

Sure, I sent the .glyphs file yesterday to support at… hopefully you have received it.

The reason for this is that the Variable Font Origin (set in Font Info > Font > Custom Parameters) does not have a corresponding instance set up in Font Info > Exports. In your case, the font origin (the Light master) is at wght=216, whereas the nearest instance is the Light style at wght=200. There is no instance defined at wght=216.

But Adobe menus for VFs default to the origin, and will add a menu entry for the origin if it is not reflected already in the instances. And this is exactly what happens here.

For cases like this, there is a parameter called Variable Font Style Name but it seems to be defunct at the moment. This is a bug in the current build, will file a bug report. (Edit: that parameter is deprecated)

In the meantime, you can circumvent this in a few ways:

  • for the Variable Font Origin, pick a master that is represented in the instances, e.g. Thin in the case of your file
  • or add an instance at the designspace coordinate of the Variable Font Origin, and call it Default, Roman, or Upright, or something like it
  • or move the nearest instance to the designspace position of the origin master
  • or the other way around: set the designspace position of the origin master to that of the nearest instance

The last two options will change the look of the Light instance in your case. And potentially of the nearest interpolated instances too, but those would just need a small adjustment of their respective wght coordinates.

To add to this, the Adobe font menu should use name ID 17, Typographic (‘Preferred’) Style Name, as the fallback entry, not the axis name, so this may be an Adobe bug as well. In the OTVAR exports, ID 17 was set correctly though.

Thanks, that solves the axis as style name issue.

How about the question where Glyphs 3 adds “Regular” to the variable font name? This seems like something that is possible to avoid, as Glyphs 2 exports variable fonts without adding anything.

That is the style name of the variable font. You can determine it with the style name in a variable font setting in Font Info > Exports.

Sorry but I don’t understand. How exactly do I export variable fonts without a style name in Glyphs 3?

There must be a style name. You cannot leave it blank. You need to set it in the VF setting.

InDesign will not display it if you have an instance on the origin master coordinates.

I’ve already fixed the font origin to point to Thin master (instance also present there).

Still, the exported font has “Regular” added to the family name. My question is, how do I export the font from Glyphs 3 without this style name addition? This must be possible as Glyphs 2 exports it fine.

Here’s two forum topics about the same problem:

The name after the family name is the style name. A font, also a variable font, must have a style name. I would not look into removing the style name, but setting a sensible style name, like ‘Roman’ or ‘Upright’.

Do you see the difference between both files in the current InDesign? Can you show me screenshots for both?

Asking because different InDesign versions are handling it differently. And Adobe has been changing quite a few things recently.

Do you mean screenshots from the Indesign’s font menu or something else? I tested in latest Indesign version (16.3.2). Both fonts show up exactly alike, with no style names. Weight list, PDF exports and all is just as intended in both. So basically I find no problems in Indesign for either version.

But in FontXplorer, Glyphs 3 version still looks like the Regular weight (even though font origin is Thin) and “Regular” style name has been added. Glyphs 2 version displays Thin origin correctly and no style name has been added.

Drawbot lists Glyphs 3 version with the style name and Glyphs 2 version is without the style name just as it should be.

So looking at this I think a variable font CAN exist without a style name.

It is how the software chooses to display this. A font cannot have no style name according to the spec.

You can compare the name tables of both TTFs in FontTableViewer. And see what triggers it. Then you can add a custom parameter for changing the name table entry in question. But be warned, you would be trying to introduce a hack to circumvent a bug in third party software. Better to have the third party fix their software. (Which they will likely do anyway at one point, and then the hack may break.)

Thank you, for giving closure to this. I was already prepared to TTX the files but FontTableViewer is a much better idea. NOTE: the download link doesn’t work at the moment in Chrome – works in Firefox though.

Better to have the third party fix their software.

I knew you were going to say this, but I’m not so optimistic :grinning: