Exporting and Installing Colored Font

Hello,

I’ve created a font that has multiple masters. Everything has been smooth so far, but once exported as OTF, installed in Fontbooks, and brought into Adobe Indesign, the font isn’t showing up. The installation preview for the font is also blank in Fontbooks.

Have I missed a step to combine the masters somehow in one image? The colored fonts tutorial says to export as regular (this is my first time with Glyphs).

Thanks!

Read this:
https://www.glyphsapp.com/tutorials/eliminating-font-cache-problems
https://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

Okay but that doesn’t change my problem, the layers are not exporting together. Please offer a solution to combining the layers…

I have re-exported; I should also add that small bits of a dark color show up in the preview (I’m assuming this is one layer that shows) and I’m not sure why one but not all masters have exported in the font.

You said the font is not showing up. What exactly do you mean by that? Not showing up in the font menu?

Again, do not install in Font Book. You will run into font cache problems if you do.

Which kind of color font are you trying to make? Which tutorial are you following? InDesign supports only SVGColor Fonts and Layer Fonts.

Thanks for the quick response.

I’ve exported to the application support/adobe/fonts folder (and copied the OTF into Indesign’s font folder)

This is a layered colored font, multiple masters (all parameters are matched horizontally and vertically to First master). I’m using the Layered fonts tutorial. So in Indesign, the font use “usable” I can select the name and everything, but it just shows blank when I am typing.

Can you post a screenshot of a layer in glyphs?

Also, I deleted the Regular layer in this export, the typing preview is showing a light grey default font in the bg. Trying to bring back the original “Regular” master from an older file and copy metrics…

Do you really need so many masters?

And what do you have in the Instance? Do all masters have a unicode width/wight setting?

Hi,

The masters are for different coloured layers. There is only one instance and that’s for the weight. Sorry, I’m still new to the program. Is there a place I can send my file? I just need to export (have layers show up when it’s being used). Also the preview has a grey bg in type mode so maybe I did something wrong with the first layer but I can’t bring it back the same as the original Regular layer was…

If you list to export as a layer font, you need to have an instance for each master (there is a function to add them all at once).

Otherwise you need to add a Color Layers to SVG custom parameter.

1 Like

Do you have a source on how to do this? A link or tutorial

Adding instances for each master is documented in the Layered Color Font tutorial:
https://glyphsapp.com/tutorials/creating-a-layered-color-font

Okay, it makes sense. But when I try to “Add an instance for each master”

I get this:

49%20AM

I followed the tutorial and made everything the same on each master, all values and settings to avoid “interpolation”?

I don’t know what I’m doing wrong. It seems one layer shows up and the others do not.

This is what the font should look like.

**Should I be worried about this light grey in the bg?

The light grey appears when there is nothing in the standard master layer. It’s something that happens, but ideally Glyphs should disable it when there is something to show in the colour layers.

The masters need different settings for weight, width or custom values

Each master needs a unique set of numbers in the weigh/width fields in Proportions. As you don’t have weight and width, use numbers from 10 to 1500 in ten units increments in the Weight field.