Exporting Diacritics

Hello

I have encountered a problem regarding diacritics when exporting my typeface.
For one example the circumflexcomb glyphs is not titled with it’s name in the otf
but as unicode. Also the spacing in the otf is off. The combinations with the glyphs works regardless tho
also the position is right.

(The file contains circumflex and circumflexcomb as well)

Please see the attached pictures.

Thank you for your help!

Combining marks need to be zero width in a .otf font. Because editing them like this is annoying in Glyphs we allow them to have space and remove that space on export. For historical reasons, the left side baring is moved to the right instead of just collapsing the width.

And the name change to follow the “Adobe Glyph List For New Fonts”. Some glyphs are allowed a proper name, all others will get a “uni” name.

When you uncheck “Keep glyph names from imported files” (in Preferences > User Setting) you get the names back on import.

Thank You Georg!

So there is no mistake here, everything as it should be right?

Correct, everything as it is supposed to be. Read about glyph names here: https://glyphsapp.com/tutorials/getting-your-glyph-names-right