Exporting name with space

Hi, good afternoon!

I’m tryin to export a font with two words “Word1” and “Word2” and I need to export it with a blank space between. I’m so confused because when I use capital letters, the font exports correctly (WORD1 WORD2.otf), but I need to export it in small caps and my exporting result is always without this space between the first and the second word.

Can you please help me with this issue?

Thanks

Be default, the file name is the same as the postscriptFontName. And it contains no spaces.
The family name in the font will be as you set it.

You can control the file name with the ‘fileName’ parameter.

I’ve tried to introduce a file name adding the instance family name to my font, but when I export it, the result is again without any space between the two words both in the .otf file and in the Adobe interface.

Can you help, me please. If it helps, I can send you som screenshots.

Thanks in advance

How exactly are you testing? Are you using the Adobe Fonts folder?
http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

Can you send a screenshot of the instance settings?

No, I’m using a different folder to export my fonts.

To be honest, I don’t think this is the problem because the file also appears without space in other applications like the Font Book.

I attach you the screenshot you asked for:

It looks like you have two spaces between the words Nandu and Jubany.

Don’t install an unfinished font in the system for testing. What you see in the Adobe UI is probably a font cache problem. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Thank you very much!

Your help solved my problem and you were right! It vas a cache problem.

Best regards,

Gerard

1 Like