Exporting with custom parameters freezes and crashes Glyphs

Hi forum!
Second round of trying to make these parameters work, you can find the first discussion here:

I’m making a rounded version of a font, which goes from condensed to regular width and both slants. Interpolation generates kinks. I’ve tried fixing them after export with RMXHarmonizer but apparently both in G2 and G3 RemoveOverlap converts unaligned smooth nodes into corner ones before sending the paths to the filters.

So, I’ve unticked RemoveOverlap and applied it as a custom parameter after RMXHarmonizer. “Problem solved!” I uttered. Turns out there’s a bigger one: when exporting the fonts (144 in this design) with this configuration, the export gradually slows and eventually stops at always different steps: sometimes the files are 95, sometimes 22, etc.
Looking at the CPU Load, it comes to a staggering 98% during these phases and then drops to 20% and Glyphs dialog keeps rolling for hours without adding any file to the batch. When canceling the export, Glyphs freezes and must be force-quit.
I think the problem lies in how the dekink parameter interprets the curves if they’re not merged before, but I’m clueless on how to solve this.
This happens in G3, in G2 dekinking creates bugs in extremeless curves like the ones shown in the F below, and in many cases I want to go extremeless, otherwise the harmonizer will mess up small paths.

screen_shot_2021-04-28_at_9.46.42_am

Kinda complicated issue (sorry for the long form)…
Any suggestion on how to pull this off?

You could remove the rounding from the file and apply the “Round Font” filter on export.
Can you try the latest cutting edge version (3080) I have fixed an issue that might be causing this the other day.
Could you send me the file that I can check the performance issue?

1 Like

Thanks for the fast reply, as usual!
I’ve tried the Round Font filter, but it gives me partial results (sometimes too rounded or just softened), especially with complex shapes like the arrows or ampersand that have several different stem widths. Is there a way to apply it with more control?
I’m using the last cutting edge version and I get the same problem.
What mail can I send you the typeface at? Thanks for taking a look into this!

Send the email to support at this domain.