Failed to import a path from illustrator to glyphs

hi there,

I tried to import a path from Illustrator to Glyphs, but it doesn’t work. (no warning box either)
I’ve done the coordinate setting in Illustrator, but it still doesn’t work.
someone with the similar problem has posted here a while ago,
and I’m just wondering if the problem has been resolved.

thanks.

Can you reproduce this with other paths too? Did you check your clipboard settings in AI?

how should i do the clipboard setting in AI?

thanks

I just tried everything again, and can confirm that the setting does not matter in AI CC 2017. I had assumed enabling PDF would be necessary, but whatever the setting, I can paste it as expected.

After pasting in the glyph, what does your grey info box look like? Something like this:

If you have this extra box next to the big box, then something is selected, which means you did paste something. It tells you the position and the size.

Secondly, you did read this one, right?
https://glyphsapp.com/tutorials/importing-from-illustrator

It could be that you have some Smart object or something. Convert it to old boring outlines.

I’m using Illustrator CS5, and the grey box does not appear either.
I did read the tutorial
I kinda solved the problem by pasting the path from Illustrator into Indesign first
and then copy the same path from Indesign into Glyphs. it works that way.
But still copy and paste doesn’t work from Illustrator to Glyphs directly.

In AI CS5 Prefs->File Handling & Clipboard, do you have AICB and Preserve Paths selected? Also, you don’t mention which OS version you are using. I use 10.10.5, direct copy and paste works for me in AI CS5 to Glyphs 2.4.1 [942].

Make sure the path you are trying to copy does not have an Appearance setting to it (e.g. shadow, or a pattern).

I’m using Mac OS 10.9.5 and Glyphs 2.4(939) trial version.
I checked the AICB and preserve paths, but it still doesn’t work.

I’m testing with a simple square to copy and paste. it has no appearance setting.