FamilyName begins or end with space (error)?

Hi Everyone!
I’m new here and just bought GlyphsMini2 a few months ago. I work for a sign company. I’m trying to convert an OTF font that a customer sent in that has some naming issues. The font style is showing up as Medium in Illustrator, even though it really should be labeled as Bold. The only thing that is Medium(normal) in this font, is the width setting. I was just trying to edit the Family Name and I get the error listing in the subject line. I tested changing the name on another Pro OTF font that I have and it didn’t give me the same error. I can’t find any info on what the problem is. I ended up using FontForge to convert it. I’d prefer to use Glyphs though since I bought it. Does anyone here have an idea what would cause this?
Thanks!,
Simon

In Font Info (Cmd-I), just click in the family name, select all (Cmd-A), and retype the whole name.

Ah thanks mekkablue! That worked.

Is there a reason you can’t just edit the existing name in cases like this, instead of having to retype the whole thing. I was just deleting one word?
(for instance in this case “Memphis LT Pro Medium” was changed to “Memphis LT Pro”)

The reason was most likely that your editing missed an invisible character in the name.