Features calt, dlig rules no longer display in features window

I’m a first timer. Was having success with contextual alternate sub rule and discretionary sub rules. Thought I would try my hand at adding a ‘kern’ feature’ but couldn’t get that to function so I saved and quit. Upon opening the project later ALL of the calt and dlig rules were gone. They still function in the edit window but they no longer display in the features tab. What would cause this?

Why would you put that in the kern feature? There are specific features for that.

Can you send me the .glyphs file please to support (at) (this website without www). I will have a look.

Also, which version of Glyphs are you running?

https://www.glyphsapp.com/tutorials/contextual-kerning

I was trying to add kerning rules per this article. The screen shot in the article clearly shows “kern” in the features tab. As soon as I added it all of my calt and dlig rules were removed from the features tab. I can’t get them back even if I try to retype them in.

This is what it looked like before.
below is what it looks like now.


the syntax I was using in the kern feature window was:
pos F 20 [b h l k];

I"m running glyphs 2.3

I received your file. The feature code is there.

Telling from the screenshot, I believe you dragged your separator line up too far. It seems butted against the grey area that carries the generate feature automatically and disabled checkboxes. Try and grabbing it and dragging it down.

You can keep the automation on for both aalt and the Languagesystems, btw.

That’s embarrassing. You’re right! Sorry to waste your time on that but THANKS for discovering that.

Don’t worry, happens in the best families :slight_smile: