File creates a glyphspackage while working on it

This might be a question already resolved, but I don’t find an answer to this. When I open my older font Kaius in Glyphs 3, It always creates a .glyphspackage while I am working on it. This is not good for the Google Drive and I have to move the files to my laptop to be working on them …

In this release note it’s mentioned that saving like this is not done any more for smaller files: Glyphs 3.0.1 released | Glyphs
Is it then that my file is just too extensive?

Is there a possibility to disable this? I don’t have this problem with any other font file, just with my font Kaius, which has a very extensive character set.


You mean the “Autosave” files? How many glyphs do you have?

Ah yes its the autosave – I have 3311 Glyphs in the upright file.

I added a user default setting to always use the single file for autosave.
In the next update, you run this in the macro panel:

Glyphs.defaults["GSAutosaveAsSingleFile"] = True

Great! Thank you so much!