fileName parameter ignored with UFO export


I have a font with family name “Foo Bar” and a “Regular” master and instance. In the master (also tried in instance) I set “fileName” to “FooBar-Regular” (to avoid the space between “Foo” and “Bar”), yet the exported .ufo for the “Regular” master is “Foo Bar-Regular.ufo”.

I’d expect the “fileName” custom parameter to get applied to ufo export as well.

In fact, I’d expect the ufo export to also apply the same automatic file name transforms (remove spaces) as the otf/ttf export in the first place.


Why do you need the space removed? File names are fine with spaces.

The “fileName” parameter only works in instances for .otf export.

Preference when working with the generated file in the subsequent workflows. I guess my point is that the parameter does not act like I expect, and that it would be nice to be able to overwrite what file name gets output.

Maybe the parameter should be name otfFileName if it only applies there.

The parameter is not support in masters as you see that it is not in the list and it is greyed out. That means it works as expected ;).

I get that as a request to add a “ufo file name” parameter in the masters.

Roger that. Feature request and request for clearer documentation then :slight_smile:

I think all in all Glyph’s approach to letting users primarily choose only a folder is quite good, as it enforces reasonable file name structure. Maybe it would be better to re-think the export destination dialog, adding something like an pre-checked “Use standard file name” which can be unchecked and lets the user write out their own file name (for whatever file format).