Files saved on High Sierra no longer opened on Mavericks

After several hours of work in my laptop (macbook Pro + High Sierra) I wanted to go on working in my iMac (Mavericks) but files cannot be opened. I tried with different files, copied them to my macBook Pro, opened them in High Sierra, copied them back to my iMac tried to open them in Mavericks. No way (see error message below). The same file works fine in High Sierra.
I need to work out of my office quite often and updating my old iMac to High Sierra is not an option. Any suggestions?

Do you have the same version of Glyphs on both machines? If not, what versions do you have?

Yes, I do. I first thought that could be the problem and I updated to the last version in both computers: Version 2.5.2 (1176).
It did not work. I also re-installed in my iMac the last stable version from scratch and updated it later. Did not work either.

I realized the files that I could open in High Sierra but not in Mavericks had several tabs open in Edit view. Closed all of them and problem solved. No idea about why this happens. You may know better. It would be great it you could look into this and fix it so that closing tabs is no longer needed to exchange files with older operative systems.

Can you send me a file that didn’t work in Mavericks?

I just sent it in a message.