Filter working on components I'm trying to exclude

I have a pixel font built with square pixel components. I am trying to set up an italic instance that uses a Transformation custom parameter to slope the letters, but I don’t want the individual pixels themselves to slant, just their locations in the exporting glyphs.

I thought this would work by setting up a custom parameter that applies the slant, and excluding all my pixel glyphs from it. But in the generated font, the pixels are slanted (though they appear correct in the Glyphs preview pane). I’ve tried the custom parameter as both a Filter and a PreFilter.

Can you try to use a ‘PreFilter’? That is applied before decomposition.

See my last sentence; already tried that.

Can you send me that file?

It seems that it slants the components, not the paths. I can’t really do anything about that.
You could add a Prefilter that slants the pixels in the other direction.

Okay, thanks for the workaround idea.

Then I’d suggest that the preview pane in Glyphs be made to slant the components as we see happens with the generated font.

I have a similar problem. I‘d like to use the PreFilter parameter to create a preliminary slanted Italic to a Roman serif cut.

If I use PreFilter: “Transformations;Slant: 14;”, corner and cap components get messed up, see screenshot (tried various alignment options, stuck with “X=original alignment”).

If I use PreFilter: “Transformations;Slant: 14;include:o” to only apply to selected glyphs, nothing happens.

Perhaps there‘s a way to completely decompose the cap/corner components before slanting to prevent this?

Also tried LayerGeek with no luck, perhaps I just don‘t know the correct order of filters.


can you send me the file?

Sure, here it is. Thanks for looking into it.
Roman-Slant-Prefilter-Test.glyphs (7.5 KB)

This is only a problem with the preview. Exporting works fine. I’ll have a look at it.
And I would add a ;exclude:_corner.flat instead of the "include:o;`

Hmm, strange. I get no transformations upon going File > Generate Instances with these settings. Tried both Filter/Prefilter.

I am on latest Glyphs 3 (3053).

No, File > Export > OTF.

Ahh, I see, thanks.