"Fix glyph to glyph kerning between letters and punctuation/numbers"

In the lastest update there’s this note. Please explain what this was…? Since we’ve been doing kerning for this exact case…

There was an issue with letter-nonletter kerning when you did it across multiple scripts, e.g. Greek and Latin and Cyrillic. It has been resolved now, you can keep kerning.

I have a similar problem where kerning between Latin letters and punctuation does not get exported. Is this what was happening? It still happens for me in 2.4.4.

Can you send me the .glyphs file? And did you try in 2.5 (you can have both versions next to each other. duplicate the app in the app folder, rename it to ‘Glyphs Beta’, open the code, activate the cutting edge versions and update. Then deactivate the cutting edge again to not accidentally update the wrong version).

And to reduce the confusion, und this in the macro window:

Glyphs.defaults["GSShowVersionNumberInTitleBar"] = True

That will display the version number in the upper right of the window (only in version 2.5 but that is all you need).

A bit related but I selected that option to not show warning again when opening a file from a previous version, how can I re-enable that?

Glyphs.defaults["GSDontShowVersionAlert"] = None

Thanks for your quick reply Georg!
I tried the Beta version, but to no avail. Eventually I remembered to check the custom GlyphsData.xml that I am using, and found that the culprit, the comma, had been assigned the script ‘other’. Comparing it to the default file and changing this value fixed it for me.

Please remove all entries that you don’t need to change from your GlyphData file. It only should contain a couple hundred lines.