Font info > Masters > Add misfunctionning?

first of all, congratulations for your software interface! There are some bugs but the ovrall concept is very ergonomic.

I have an issue when trying to add a bold version of a font that I’ve created on an separate file.

When I add the bold to my regular version, I have both in the Masters menu list (OK), I have the main bar button updated (OK) but when I click on it, I see always the bold version. The regular one seems to disappear :frowning:

When I try to delete the recently added bold version to go back to my regular one, Macintosh gives a generic sound error (no error message) and the bold version persist.

Hi Jan,

Thanks for you interest in Glyphs.

You used the add button to add the other master to the regular? You have to tell the second master, that it is a Bold face: go to Font Info > Masters > select Bold face > Proportions > set weight to Bold.

If that does not work, could you send me the two files in question?


yes I’ve made as you say. I’ve looked at the video 4-5 times :slight_smile:
Is [edited by the Admin] your email ?

By the way, there are other little things I don’t get…
for example I cannot understand how to automatically create accented letters when I update gliphinfo. Can you explain it please ?
Maybe with the “generate gliphs” command? But it seems to add no gliph…

And the export to otf doesn’t work (message: “The operation couldn’t be completed. (Cocoa error 11.) There is no Instance defined.”).
But, what an instance is ? and why when I click on the “create instances” menu button, I have a generic Macintosh error sound (I’ve tried all combinations/selections but nothing happens) ?

I’m on MAC OS 10.6.3

sorry I'm quoting, but the "edit button doesn't work"; I'd like to specify that yes I've made as you say but It didn't work

Yes, that is my mail.

to generate glyphs:
You go to the font view, open the Latin section on the left sidebar, right click for example “Western European”, in the popup you select all glyphs you want to generate or cmd+a and hit “Generate”.

The thing with the Instances:

  1. I Font Info > Master: set a distinct value for the wight (next to the popup). I suggest the width of the standard vertical stem. (I take it from the “n”).

  1. Font Info > Instance generate a instance and specify a value for the Weight in the Interpolation section.

Then the export should work.
Hope that helps. I really need to update the documentation …

An I fixed the edit in the forum.

Thanks! greatly useful informations :slight_smile:
I can export now in otf.
Is it normal I can’t edit the Weight value in the Interpolation section ? It is in black (it seems editable) but I cannot write inside, so it keeps the 0 (zero) value.

In fact I’ve never used FontLab, so I’m afraid I do not know any functionalities that are well known by the others.
That means too I can be a very good Beta tester :slight_smile:

The disabled Weight value is should be enabled if you save the font, and reopen it. Will fix this soon.

This Functionality not at all available in FontLab. I used a python script in FontLab to work similar like it is now integrated in Glyphs.

And I really appreciate your effort understanding and using my app. Thanks

It’s because I like your app.

Even if I restart the app, I cannot edit the interpolation value.

More updates to your forum soon, I think… :wink:

Thank you

Can you send me the glyphs file. Than I can have a look.



Hello! have you found the issues in the files I sent you.

I also have a suggestion :
you told me « You go to the font view, open the Latin section on the left sidebar, right click for example “Western European”, in the popup you select all glyphs you want to generate or cmd+a and hit “Generate”. »

It would be amazing if I could do the same with punctation. At present I have to create all the symbols as " “ ’ ect by hand.

This is added in the most recent version.