Font naming problem

Folks, I’m having a problem with exporting font with a proper name. The font has only one weight and it’s bold, hence there is only one instance. Whether I try to export with an instance name bold the full name of the font is exported as font name + bold. Which does look rather strange in Adobe products:

https://infinit.io/_/L44zkQL

Though if you rename the only instance into “Regular” then full name of the font is just that — font name without any unnecessary additions. And it looks exactly how I want it to look in menus, except that the name of the weight is wrong of course.

I did read this topic: …/glyphs-trial-all-exports-are-regular/522/16, but adding any of mentioned parameters in the instance tab makes no difference. I’ve then tried to manually adjust features file in the /temp/ folder, but I’m having a problem with generatefont.command.

The error message I’m getting:

https://infinit.io/_/XuvjZXV

I’ve checked read/write permissions on both glyphs app and font assets, all fine. So where do I go from here? Should parameters work on Version 1.4.4 (609) or how do I solve that generatefont.command. Sorry, it does look very much like the problem already solved and described in detail, but I can’t figure it out myself.

Many thanks!

Because of the sandboxing restrictions, you would have to install makeotf yourself before running the command:
http://www.adobe.com/devnet/opentype/afdko.html

You need to make sure that the family name does not have Bold in it, and the style name of the instance is Bold. And are you using the Adobe Fonts folder for testing?
http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

Make sure you remove previous exports from the folder.

Thanks! Yes, I am exporting only to Adobe Fonts folder from the very beginning. It’s not a caching problem, as I can see all changes right away when altering names with parameters (or via input fields).

Family name does not have Bold in it. I did successfully export font with the right name, but for that to work I need to specify wrong weight (regular instead of bold).

It just seems to me that when a family only has one weight and it’s not regular, something under hood tries to automatically include that weight name after the family name.

I did download makeotf from Adobe just now, thanks for the link. Unfortunately it spews outs even more errors I have no clue about, but I presume it’s already an Adobe forum that I need to visit.

Anything else that can be done via Glyphs interface? Is there a parameter that specifically controls family name and ignores every other rule/hidden instruction that tries to alter it without me knowing?

Up until now I was using this:

compatibleFullName

Compatible full name (Mac only). Corresponds to the OpenType name table name ID 18. If not set, the value for name table ID 18 is calculated from Family Name plus space plus Style Name of the respective instance. ‘On the Macintosh, the menu name is constructed using the FOND resource. This usually matches the Full Name. If you want the name of the font to appear differently than the Full Name, you can insert the Compatible Full Name in ID 18.’

Unfortunately it still squeezes that “bold” into the family name.

Can you send me the .glyphs file? Support (at) (this website without www).

And why are you using 1.4.4, and not 1.4.5?

Sorry for late reply, was away. I’ve just sent you the .glyphs file.

I’m still using 1.4.4 because Apple Store doesn’t offer me any update. I’ve also couldn’t find anything other than Glyphs Mini in the Apple Store. I saw 1.4.5 available for download on your website, but I cannot fire it up — says I need to purchase it first. Do you think 1.4.5 can solve naming problem?

If this will be of any help to you — I’m still working on the 10.7.5 OS X.

Thank you. Looking forward to your reply.

I think it exports fine under 1.4.5. CMIIW, but this is what you want, right?

I removed all style linking info, since it is a single font only:

Yes, thank you. This is exactly how I want the name to look. So 1.4.5 will solve that, right? Because I’ve tried removing style linking before.

Now two questions speaking of 1.4.5.

  1. How do I get this version if I’ve bought Glyphs through Apple Store and they don’t have 1.4.4 —> 1.4.5 update up? I don’t have the license file either because of that.
  2. Does 1.4.5 work under OSX 10.7.5?

It surprises me that 1.4.4 doesn’t do it. Which version of the Adobe apps are you using? Perhaps you want to send me the OTF you generated with 1.4.4, and I’ll test it on my installation, to exclude some Adobe function interfering.

Frankly, I am not sure. Apple’s terms prevent us from simply handing you a Glyphs 1 license file. Perhaps @GeorgSeifert can give you a temp license file.

Yes.

I have attached OTF together with .glyphs file to my last letter. I’m using Adobe Creative Suite 5 and was testing in AI and PS. I don’t think it’s Adobe though, because even if you hit File Info in Finder you can see — among other properties of the .otf — the “Full Name” string and it does include “Bold” in the full name already on that level.

I saw Georg’s messsage. Thank you! Hopefully I will find the email with purchase — it was years ago.

Hello, hello! I’ve replied to Georg last week about the license and supplied the app store purchase email, but did not get any response. Maybe he’s away, or my message got stuck in the web. Can you please let me know if this is going ahead? Thank you in advance.

I was writing him to forum@glyphsapp.com

The email is not good. Use ‘info’

Thanks! Sent.