Font-wide alignment control

Good Morning,
I’m recently editing a pixel font which was set up by another designer in Glyphs Mini first and Glyphs 3 (3151) later. I’m using Glyphs 3184.
Each glyph is built of components referring to one single “master pixel”. Automatic Alignment is enabled. As soon as I try to apply any changes or save the file all the glyphs collapse: the pixel components are then sitting side by side on the baseline spaced as the origin pixel glyph.
How can I avoid this problem?
I’ve made a few tests and found that disabling the automatic alignment would keep the intented letterforms.
Is there a possibility to disable automatic alignment font-wide instead of shifting from glyph to glyph?
Or do I have a better way to avoid collapsing pixels by some settings?

Thank you very much

To disable automatic alignment for all glyphs in the font, regardless of selection (paste and run in macro window):

for glyph in Font.glyphs:
    for layer in glyph.layers:
        for component in layer.components:
            component.automaticAlignment = False

Can you post a screenshot of before and after you save your file, so the different states that automatic alignment results in?

1 Like

Or, disable alignment in Font Info > Other.

1 Like

The line of pixels is what happens after editing and saving.
Thanks for the macro script, but I would rather choose Georg’s advice with checking the item in Font Info.