Font window doesn't show non existing glyphs


#1

I imported through ufo one experiment containing capital E plus 6 lowercase glyphs created in FL. Now I’m not able to add glyphs, as font window is showing only existing glyphs, but no others (in light gray). I even can’t use type tool in character window to add new glyphs. Sure, I can create new document and copy there all letters, but I’m wondering where might be the problem.


#2

The screenshot shows you selected to display only the Basic Latin (A-Z, a-z) in the sidebar on the left. Click on All at the top of the Categories in the sidebar.


#4

Same thing with “All” category


#5

There are only these ten glyphs in the font. And you can probably delete this .notdef and the glyphOrder parameter in File > Font Info > Font.


#6

Read this: https://glyphsapp.com/tutorials/adding-glyphs-to-your-font


#7

Deleted .notdef and glyphOrder parameter with no change in font window. For me was easier to copy existing glyphs into new document.


#8

If you open the Latin section in the sidebar, you can right-click to see which glyphs are missing. Then just select the ones you want and add them by clicking ‘generate’.


#9

The problem was, that there were no empty glyphs in the font. The app does not display slots for glyphs that do not exist in the font. So you have to add the ones you want in your font, e.g. like Ben showed you.


#10

When you open a font from somewhere else, Glyphs doesn’t add empty glyphs for missing characters. It only does this when you create a new font document, creating empty glyphs for the following characters: ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789.,-


#11

Ok, thanks, understood!