Fractions break in InDesign when I use localization

Not sure if this is the place to ask for this, but anyway I have no other options. I have Bulgarian localization and fractions which work perfectly together in Glyphs app, but whenever I activate both features in InDesign, the fractions feature isn’t working.

Any ideas what’s going on, and how can I fix this?

What does your locl feature look like? Can you paste it here?

Could also be a bug in InD. Does it work with other fonts that have Bulgarian localisation?

It happens with my file too! Top is set in Punjabi. Bottom in English. And some calt features don’t work too, like in the o.

This might have to do with the languageSystem settings and the script the context features are registered for.

I think I’m having similar issues in InDesign where, when I export my font with locl enabled, none of the opentype features in the font—liga, calt, fractions, etc—work at all.

But the ccmp feature is causing the same problem, too, in both InDesign and Illustrator. If I export the font with ccmp enabled, the opentype features break in both programs. If ccmp (and locl for InDesign) are disabled, the font works fine.

Both locl and ccmp are being auto-generated by Glyphs though… any thoughts on what’s causing it or how I can fix them?

Can you send us the .glyphs file?
I suspect the languageSystems are out of date or incomplete. Does updating them solve the problem?

Here is my locl feature:

script latn;
language ROM;
sub Scedilla by Scommaaccent;
sub scedilla by scommaaccent;
sub Tcedilla by Tcommaaccent;
sub tcedilla by tcommaaccent;

language NLD;
sub iacute j by iacute_j.loclNLD;
sub Iacute J by Iacute_J.loclNLD;
sub i j by ij;

language MOL;
sub Scedilla by Scommaaccent;
sub scedilla by scommaaccent;
sub Tcedilla by Tcommaaccent;
sub tcedilla by tcommaaccent;

script cyrl;
language BGR; 
sub @locl by @loclBG;

And here is my frac feature:

	sub slash by fraction;
	sub @figures_standard by @figures_numerator;
	sub fraction @figures_numerator' by @figures_denominator; 
	sub @figures_denominator @figures_numerator' by @figures_denominator;

(I tried with those features automatically generated by Glyphsapp but nothing changed)


languagesystem DFLT dflt;
languagesystem latn dflt;
languagesystem cyrl dflt;
languagesystem latn ROM;
languagesystem latn NLD;
languagesystem latn MOL;
languagesystem cyrl BGR;

what happens if you add a script latn; to the beginning if the frac feature?

With script latn; the fractions doesn’t work at all when Bulgarian localization is selected.

I think the reason for this is in Indesign. Try changing between Adobe World-Ready Paragraph Composer and Adobe Paragraph Composer.