G2: buggy listings of sidebearings

In list view I’m seeing many of my letters with diacritics listed with just the numeric values for Width, LSB, and RSB. If I double click on a glyph to open an edit tab with it and return to the font tab, I find the glyph now (correctly) has the “auto (n)” entry for those fields.

I am having the same troubles. I am trying to apply a simple spacing in the list view. While editing, previous corrected or added values are changing automatically, e.g. 10 becomes a 9 or 8…

Also, the auto settings are getting lost along or a “==” is added randomly in one master…

I find this loose of control quite worrying. Is there any other way to apply or write spacing / kerning values so they stay as I edited and intended them to be and do not change randomly?

If your glyphs are build of components and auto alignment is working, you can’t change the spacing for them - that is the hole point of the auto alignment. Then it will always show a “auto ()”.

The “==” means that the layer has a metrics key. Only one equal sign means the glyph has one.

Can you be more specific what you mean with “loose of control”?

Thanks Georg, I am aware of the “==” function and the concept of the auto alignment. Which I love and works well in general. I will try to explain my problem:

I have worked on spacing from down the list view, starting from A downwards (to Z) looking through all Masters (four in total), making corrections. When I was deeper down and looked back up, I realized that the corrections I have previously made, have been changed magically. Some “==” where randomly added here and there and sometimes the auto function did not apply all though it should…

I then, like eliason described, double clicked on the glyph to open an edit tab with it and return to the font tab, I find the glyph now (correctly) has the “auto ()” entry for those fields.

Regarding random “==”, after working a bit more, I think it mostly went like this: when I apply a reference letter in the spacing, say I enter H in the left D spacing section (it had a numeric value before), the values show: H (80) for example but in the bold master it shows: ==H (80) but the thin, regular and black is fine > H (0). So when I now would like change back the reference letter to — lets say e.g. A — thin, regular and black would have the new reference A > A (25) but the bold master would still stick to H (80) …

I hope you get what I mean…

I also should mention that I have copied values from another, earlier version of the same font.

Thanks for your help! Still love Glyphs :smile:

The == are most likely a leftover from Glyphs 1. It could not differentiate between layer and glyphs metrics keys so well.

Sorry Georg, but I really getting desperate here. Yesterday I worked through the whole file, corrected everything and all was fine. Today I opened the same file and the values were changed again. I am attaching two screenshots.

The Thin master is as I intended and implied it (second one). The Bold master looked like the Thin master yesterday but today it has the automatic function switched off and again, added random “==” here and there.

Can you help?

Can you send me the file?

The compounds should read auto. Perhaps re-compose them? I.e., select a glyph, then choose Glyph > Make Component Glyph. Careful, it will reset non-standard composings. But you have per-glyph undo.

Thanks Rainer, but the re-compsing didn’t had any effect either.

Georg, I’ve sent you the files (to the info@ address). I assume I better stop working on them while you at it?

It is just a display problem. Scroll through all glyphs in all masters in grid view and it will show correct values. I’ll fix this.