Generated diacritics glyphs widths

I’m very new to this app and have spent countless hours so far trying to get up to speed on it. I’ve read (and re-read, watched and re-watched) the tutorials and I can’t figure out what i’m doing wrong (although I am positive i am doing something wrong!)

When i generate new glyphs (e.g. é from a normal e) they are not positioning correctly. In this example my base e might have a width of 584, but the acutecomb glyph might be set at 600 wide (default). The resulting eacute glyph ends up 600 wide (so wider than standard e). This knocks the alignment of the acutecomb off centre as it is centring across 600, whereas the e glyph is centring across 584.

On some glyphs like e a o c this is only a subtle misalignment, but some others like i or w it is off by a larger amount.

Does this sound like a commonly made error?

Incidentally i can’t even get the w to work as it should, i.e. if i type option u to get ¨, then hit w, it gives me ¨w instead of a combined glyph (having said that i can’t even get a combined glyph typing on here so have no clue what is going on there!).

Thanks from a newbie!

What version do you have? And have you enabled automatic alignment in Font Info > Other settings?

  1. Do your base glyphs have top anchors, as described in the Diacritics tutorial?
  2. Are the components in the right order? Base glyph first, then the marks, from closest to furthest. Recreate them with Glyph > Make Component Glyph or use Filter > Fix Compatibility to put the components in the right order.
  3. Did you make sure File > Font Info > Other Settings > Disable automatic alignment is OFF?

There was a problem in the cutting edge versions that should be fixed in v960.

I have installed the latest version (961) and it hasn’t changed anything same issue as above.

I’m positive it is something I am doing wrong with the anchors - how do you set anchors on the base glyphs?

@mekkablue I have read that tutorial a number of times but I’m not 100% sure I have understood the whole anchor situation properly

OK - i tried adding anchors to the base glyphs (the option is available now in the menu, it wasn’t before) and this seems to be aligning them correctly now. However the newly made component glyphs have different widths to their base glyphs.

Actually - ignore the above comment - once i add the anchors to the base glyphs the widths are corrected and are referenced as (auto) in the component glyphs - my error here.