Glitches at small sizes in grunge style typeface


I’m looking for some advice on a glitch that’s appearing in an exported OTF typeface.
The typeface was drawn by hand before being scanned, livetraced and roughened in Illustrator, before being pasted into Glyphs. I followed the Glyphs tutorial on importing from Illustrator, including the recommended method for cleaning up paths.

It all looks good within Glyphs and I can’t spot any errors in the typeface, however when you bring it into Indesign several characters have small glitches. When typed out these appear, but dependent on scale. The actual font size doesn’t seem to make a difference, its the size they’re appearing on the screen.

So if you’re zoomed out on 10pt, the glitch will be there, if you’re zoomed in it won’t. The same happens scaled up at 100pt.

I thought it might just be a screen issue, but the same occurs when printed. See below:

Does anyone have any idea what might be causing this? My first thought is that its in the tidy up paths tool in Glyphs, but looking close up I can’t see anything wrong with the separate glyphs.

Here’s a few additional screenshots:

Any help would be greatly appreciated!

Thanks in advance,

Is the font hinted? It shouldn’t be:

Hi, thanks for your suggestion. I’ve gone through and checked using the tutorial you linked, and no, there’s no hints being used in the typeface. Any other ideas?

Ah I think I’ve fixed it, I unticked ‘remove overlap’ when exporting and it seemed to sort the issue. Whether it was that or I had done something wrong in the hinting tutorial before, I’m not sure. Either way its working now, thanks again for your help!

1 Like

What grid do you have?

I’m not really sure what you mean? This is my first time out using Glyphs. The typeface is to be used as an alternative to an existing typeface, therefore to get consistency I placed my new glyphs over the top of the ones from the original version, and lined them up that way before deleting the old. I’m sure this isn’t the conventional way of doing it, or even the correct… But it seems to have worked for me!

I meant the grid setting in Font Info > other settings. It should be at least 1.