Glyph 2 and Glyph 3 crash after testing Glyph 3


Yesterday I installed trial version of Glyphs 3 and tried to install some plugins that I was used to use in Glyph 2. But after a restart, I can’t open Glyph 3 and even Glyph 2, they crash even before the application is launched “Glyphs left unexpectedly.” . So I can"t send you a Glyph Report, the only report that I can send you is Apple crash report. I tried to launch them from and out of the Application folder but nothing has changed.

I tried to remove/uninstall completely both but nothing has changed.
However, if I’m connect to an other Mac session, both still working.

I’m working under macOs Catalina 10.15.7
Version of Glyph 3 used is from this archive “”

EDIT : When I launch Glyph 3 executable in Content/MacOs/Glyph3.
I have this :

" File "/Users/hugoj/Library/Application Support/Glyphs 3/Repositories/ArrangeWindows/ArrangeWindows.glyphsPlugin/Contents/Resources/", line 21, in <module>
    from GlyphsApp import *

  File "GlyphsApp/GlyphsApp/", line 5, in <module>

ModuleNotFoundError: No module named 'objc'
2020-11-21 20:27:50.969 Glyphs 3[1870:15493] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil object from objects[1]'

Hoping that you can help me.

That Glyphs 2 is not working anymore is strange. They don’t have anything to do with each other. You should be able to start by holding down Option+Shift when you start the app. That disables Plugins.

What version of Python do you have? The one you are using is missing pyObjC. You can install it from the command line:

pip3 install pyobjc

Thanks Georg,

Holding down Option+Shift work. I have uninstall all plugins and re-install modules. But when I try to install again a plugin (any of them) and relaunch, Glyph crash.

I have Python 2.7.16.
I used your command and now the in the crash report I have

2020-11-21 21:42:45.849 Glyphs 3[4148:84850] Stem Thickness has encountered a fatal error, and will now terminate.
2020-11-21 21:42:45.849 Glyphs 3[4148:84850] Traceback (most recent call last):

  File "/Users/hugoj/Library/Application Support/Glyphs 3/Repositories/StemThickness/StemThickness.glyphsReporter/Contents/Resources/", line 15, in <module>
    import objc, math

ModuleNotFoundError: No module named 'objc'

Can you install the python module from The Plugin Manager. And select it in Preferences > Addons?

I selected Python Version 3.8.2 (Glyphs), and now Glyph 3 no longer crash even if I install plugins.

Thanks a lot Georg,