Glyph horizontally cropping after export


I’m having problems previewing a stylistic set glyph in InDesign after export (please see screenshot 1). The glyph previews at around 25% zoom but when zoomed out larger or on mac finder preview it seems to disappear.

I’m mindful the glyph has a much larger width due to implementing two words within it (‘HUANLÜ 还律’). However, I’ve done this so I can easily and quickly place the two words into a given text box when needed and it keeps the correct spacing and kerning.

Is there anyway of increasing the viewing threshold so no parts of the glyph crop on preview?

This happens both in Indesign and Illustrator and only works on this particular glyph, which I assume is just due to it’s large width. It also displays and exports fine to PDF for example.


Will Hibbert

Corrected path directions?

Corrected Path Directions and Tidied up Paths but still the same problem persists frustratingly.

I’ve saved the new font into the Adobe Fonts folder too so the cache shouldn’t be effecting the new export.

How wide is the whole glyph. There is a limit of n how wide glyphs can be.
Doing ligatures like that is jot a good idea. To prevent line breaks, you can use none spacing breaks or use the break settings in Indesign.

The glyph is 14670 wide.

Do you suggest I just keep ‘HUANLÜ 还律’ to two separate glyphs instead and insert the space inbetween, rather than combine them together as I’ve done here?

It’s just weird how it previews fine when closely zoomed in on InDesign/Illustrator, but when zooming out the Chinese part just seems to disappear?

I would not rely on such wide glyphs. You will run into problems like this.

Adobe apps switch the rasterizer for different zoom levels and they have different issues (e.g. some can’t handle overlaps). That might explain the differences you are seeing.

Hi @GeorgSeifert and @mekkablue, just to give an update on where I got with this – I decided to make two separate glyphs containing the letters ‘HUANLÜ’ and ‘还律’, taking your advice to not have one wide glyph combining them together. Since making the change I haven’t had any issues up to this point with the previewing and both glyphs show at the different zoom levels within Adobe.

Thanks for both your help with this issue!

1 Like