Glyph is present in font but applications do not see it

I have a font with all possible glyphs, but when I want to use them in ie. Word I can not write it. I am talking about ‘scaron’ and almost all other Central European glyphs. Problem is, that all those glyphs do not have unicode assigned to them. In ‘scaron’ case it should be 0161.

How can I assign correct unicode to correctly named glyph so that I can use it in other applications? I am using Glyph Mini…

Have you tried selecting all glyphs and run Glyph > Update Glyph Info?

I do not see that option in menu.
Here are all commands in my menu:

I didn’t see that you mentioned Glyphs Mini, sorry.

Who did you check that the unicodes are missing?

this is what I see in the app:
As you can see, there is no Unicode, but the glyph name (scaron) is correct. And as stated, when using this font in Word I can not write this glyph (š, scaron), which is quite common in Slovene language (I’m from Slovenia).

Please advise, what can be done.

Can you send me that file?

Sure. How can I do that? Can you give me your e-mail? This is font Chalkduster.

Send it to support at this domain or an dropbox link as a direct message in the forum.

Dropbox. Great idea.
Here is link: to the file.

Better if you send the .glyphs file.

Perhaps copy all the glyphs into a new file. That should reset the Unicode values as well.

How do I save it as .glyphs file? I am using Glyphos Mini 2.
I’ve also tried with copying all glyphs into new file, but there was no change in Unicode values.

Have you tried File > Save?

1 Like

Solved it!
That’s how:

  • I’ve created a new font,
  • renamed all empty glyphs in it (btw, is it possible to remove them in Glyph Mini 2?),
  • copied all glyphs from Chalkduster.otf font
  • changed FontName and other info
  • installed it with FontBook
  • and voila! :blush::metal:

Thank you both for all your support and answers so far. I might have some questions in the future.

The original font misses those unicodes already. I see if I can improve this.