Glyph positioning

Hi, i have a problem with the positioning feature. Working on a handwritten font and would like to include some correcting marks that should overlap with the already written text.

I’m using the dlig feature for it (as there is no feature for this purpose, at least as far as i know). I’m creating correcting marks as ligatures, for example 2 or more - become a single strike out, 2 or more / will be a wavy strike out etc. The problem arises when i try to overlap those ligatures with the text preceding it.

Tried the pos before and after the ligature lines (inside the dlig) but didn’t work. First i though it was somehow overlapping with the ligatures so i tried the pos just on a hyphen to se if it works and nothing happened - not a single movement either in the x or y direction.
I tried:
pos hyphen -600;
pos hyphen <-600 0 0 0>;
pos hyphen’ space <-600 0 0 0>;

  • some others just cos i like to test all the imaginable possibilities.

What am i doing wrong?

Found a workaround by setting the glyph width to zero but would really like to figure out how to use the pos.

Hope you can help me out


What is the name of the “single strike out” glyph?
The easiest would be to set the width to zero.

The name depends on the length; hyphen_hyphen.dlig, hyphen_hyphen_hyphen.dlig, etc

Yes, i know i have only hyphen in the previous posts example, but it was just a test to see if its cos of the overlapping with the substitution. Did the same for the actual glyphs but didn’t work.

I did set the width to zero but still would like figure out why the pos doesn’t work. And eventually i would like to get more flexibility with the contextual positioning for some other corrections.

pos hyphen <-600 0 0 0>;
pos hyphen -600;
work for me (I put it in the on-by-default calt for testing), but they do different things. How do you test? Are you using the Adobe Fonts folder?

Noup, was testing it only in the glyphs preview - big mistake. But it was always working really fine with the substitutions, I didn’t even think bout testing elswhere …

It works fine in InDesign, also with the ligatures. Feeling a lil stupid now and really sorry i bothered with something that was probably working all along…

And yeah, the result i am looking for is achieved by <-600 0 -600 0>

Thank you mekkablue!

The Glyphs preview does not support positioning rules. You have to test them in the software you want to support, also because different apps do it differently.