Glyph suffix name limitation

I seem to have run into a limitation of glyph name suffixes. I am trying to add a rather long suffix, and Glyphs fails to accept it. When I try to add the application treats it as if it had no .tf suffix, and acts as if I am adding a glyph that is already present. Expected behaviour or a bug?

Hmm. Theoretically it should be but we have separate -persian and .urdu suffixes in the database. Having both four-persian.urdu and in the font triggers tnum with the following line:

sub four-persian.urdu by;

Do you need to adhere to a special naming scheme? Would defining production names with suffice?

:slight_smile: Yes, I didn’t come up with that naming scheme. But also yes, they should only be production names. Do I need to add them to the database for it to work?

You can also select a glyph in Font view (Cmd-Opt-1), and choose Edit > Info for Selection (Cmd-Opt-I), and set the production name in the following dialog.

Or, if many glyphs are affected, you can also use a local GlyphData.xml:

You can now employ local Glyph Info files . Put your custom GlyphData.xml next to your .glyphs file, or in an Info folder, or in the parent folder. If Glyphs finds it in any of these places, the content will override the installed Glyph Info. This makes it much easier to share custom glyph data for a specific project.

(works since 2.3)

I am not sure this solves the particular issue that I’m having.

I try to add a glyph called but then the application tells me that a glyph with that name already exists in the font (even though non is displayed or found when searched for):

Also, whenever I try to rename an existing glyph to the above name, the application ignores it and instead adds a copy of the glyph with a numbered suffix .001, .002, .003 etc.

It really doesn’t like my suffix after a suffix.

Maybe close and reopen the file?

Tried that, even tried the newest application update and a restart, to no avail. Also tried the same with an entirely new file, see the screen recording attached. (1.2 MB)

Which version of the app are you running?

2.6.2 (1240)

I suspect it is a problem with the automatic update for glyph info/glyph name when you create the glyph. E.g., if you create uni0123, it is automatically renamed to its nice name gcommaaccent.

What you try in the screencast should work if you (temporarily) enable Font Info > Other Settings > Use Custom Naming.

Or, what I would do: Use the nice naming scheme (e.g. and set the production name in the glyph info, as described above.

Ok, thanks Rainer. I’ve temporarily changed the name and will see if this is workable for the production setup.

1 Like