Glyphs 2.3: what are these new warning signs, and change log is broken

What are these little yellow warning signs with exclamation marks that now turn up in the font tab? I can’t find anything about them in the blog or the font view section of the handbook.

Also, the change log displays an empty box in 2.3b (830).

They mean that something is not up to date or out of sync. For now, it indicates that one of the Metric Keys is not in effect, i.e., the ‘red metric keys’ situation.

This is kinda helpful, but because in certain equations Glyphs always thinks they’re wrong, I cannot remove all of them entirely. Typically if you use fraction (e.g. =H*0.8), it never understands what the rounded value should be and changes the result depending when you click the update button.

Can you send me the file? My examples work fine.

So it should disappear after CMD+CTRL+M ? It does not here.

You need to update metrics on both masters.

1 Like

Still doesn’t work. As Tosche wrote I guess floating metrics cause this. My »M« is marked. Its metrics refer to »H«.

Check LSB of the uppercase B. It never gets “fixed” when the result is fractional.
Wrong key (557 Bytes)

I’m definitely seeing the warning icon on some glyphs whose non-fractional sidebearings are fully updated on all masters.

I fixed it.

I updated to the last version and the warning signs are still there. It is kind of annoying to see them. I have realised they appeared in all the glyphs that join at least one of the SB with another one.

It is checking all layers, even the copies. I fixed it.

OK, I have to delete or update all the layers then. Wouldn’t it make more sense just to check the master layers?

As I said. I fixed it.


I also try to keep the metrics synced in all masters via keyboard-shortcut.

This doesn’t work.

Only when do it manually in the info-box (for each master) the metrics do actualize to key …

The “Update all masters” only updates master, not the layer copies.

nice to know about the “just-sync-master-layers-situation”

But I think there was another problem; but I solved it:
trick was, to press the ctrl-cmd-M more often and then for each master …

But one letter doesn’t sync. perhaps that is the problem that has been discussed above.
Even when clicking manually on sync - nothing happend …

Try deleting the Metric Key and reentering it again.

It works, I ever tried this way.