Glyphs 2.6.1 Interpolation Issue – Masters Ignored


I recently upgraded to the latest Glyphs (6.2.1) and it seems that the middle masters are being ignored for interpolation.

My masters are:

Thin Compressed
Medium Compressed
Black Compressed
Thin Extended
Medium Extended
Black Extended

But the Thin, Medium, and Black masters are not being used for interpolation, resulting in undesired forms. And with Master Compatibility turned on, you can see the lines are not connecting to these middle three masters.

I tried opening the same file on a colleague’s computer with Glyphs 6.2 (not 6.2.1), and this was not the case. Since it works properly in 6.2, I’m led to think that this may have to do with the latest update. Is this a known bug in 6.2.1?

I’d really appreciate some help. Thank you!

Could you send me the file? Send a (dropbox) link by direct message in the Forum.

I am not able to DM for some reason. I don’t see the “New Message” option.
Is it because I just created an account? I’m not sure what’s going on.

You have a “Disable Masters” custom parameter. And it is doing its job correctly. You might what to remove it.

1 Like

Sorry to ask this here. Is it possible to turn on and off one of the masters and therefore see how my instances would turn out if I did that? Let’s say I have three masters in my font, one called ‘Light’, other ‘Regular’ and the other ‘Bold’. How do I turn on and off the ‘Regular’ master? Thank you!

Yes. This is what the parameter is meant for.

1 Like

But how that parameter looks like? What do I write in the ‘Property’ and ‘Value’ areas?

You will get a dialog with a text view. In it, you add the master names, one per line.

1 Like

Something like this?


No. For the parameter, you add the parameter Disable Master and as Value, you add the name of the master. One per line.

1 Like

Thank you so much! Will try that!

What is the correct syntax for the Disable Master parameter? Tried ‘Disable Master’ but it stays greyed out.

You should try to pick it from the parameter list that shows up when you click the drop-down icon.

1 Like

I’m checking the Glyphs Handbook pdf to see if I find the parameter. No parameter similar to Disable Master or Master Disable on the parameter list when I click the drop-down icon.

Go to the Instances panel of the Font Info window. There, for each instance, you can add a custom parameter. The custom parameter name is Disable Masters (you can also find it in the drop-down). Then, as value, add the master name(s) you want to disable, one per line.

1 Like

Thank you, will try that! Maybe in the next version there could be an ‘on and off’ option to do that quicker!

Is there a custom parameter for making the master that was disabled to be used in the interpolation again? I erased that custom parameter but my Regular master now continues disabled. What can I do to correct that?


You might need to reopen the file.

1 Like

Already tried that, but it’s not working.

Can you send me the file?

1 Like