Glyphs 2.6.7 crashes when opening OTF, TTF Files

Hi, whenever I try to open OTF or TTF Files, Glyphs freezes immediately and I have to restart. I am using Version 2.6.7 and have already updated my MacOS from Catalina to Big Sur 11.1. The error accures in both versions. Does anyone know how to fix this?

Can you send me one of the .otfs?

I have sent you one of the .otfs via email. However, the error occurs with every .otf or .ttf on my computer. I downloaded a trial version of Glyphs 3 to see if the same problem occurs – with Glyphs 3 the files can be opened easily. I even tried Glyphs 2.6.6, in this version the error occured again.

The file you send me opens file for me. It might be a plugin. Can you start the app while pressing Option+Shift?

And can you please send crash reports?

When I start the app while pressing Option+Shift it works. I deinstalled my Plugins (Show Smooth Node Angle and Proportion, StemThickness) and the scripts (Variable Font Test HTML) and it works again. I sent you the crash report via email.

Please send the crash report from the window that comes up when you start the app.

Unfortunately I don´t see a window coming up when I start the app. Is there another way? Apart from that I installed the plugins one by one and it seems that Glyphs ist only crashing when “Smooth Node Angle and Proportion” is installed.

I’ve been experiencing crashes with Glyphs 2.6.5 and 2.6.6 as well, it’s been loading slowly, regularly crashes when export fonts & tons of other issues… :frowning:

Please send all crash reports. And can you try to open the app with Option+Shift key pressed to see if that makes a difference?

The problem is it’s not really a crash, Glyphs often freezes (with the spinning wheel) and I have to force quit, even after that it won’t show up the “send report” window.

Can you try without plugins by holding down the Option+Shift key when you start the app?
And could you make a spindump when this happens? This can be done in Activity Monitor, top left in the toolbar.

Version 2.6.7 not opening on mac0S 10:13.4


I just tried it and it works fine for me. Can you try to download it again?

To George,

It works without plugins have tried this zip file but Glyphs (not responding).


Then you need to uninstall the plugins and re-install them one by one from the Plugin Manager and restart the app. If it hangs again, the last installed plugin is causing the problem.