Glyphs 2 and 3 – Bracket Layers not interpolating?

That would be really great!

Just pitching in that great if this would be solved. I haven’t been able to get the bracket-trick to work in a long time, even with the most simple of families. Would really need it for my workflow.

It used to work in Glyphs 2

Actually I just noticed that the bracket trick works in Glyphs2 on the same font, but not in Glyphs3

Do you use reverse brackets?

Bracket Layers work in Glyphs 2 and in Glyphs 3. The issue with Glyphs 2 is that they did only work in a Glyphs file with one axis, not in a Glyphs file with two axis. This issue has been solved in Glyphs 3. The issue discussed here is that intermediate Masters, which were derived from Instances, do not provide interpolation of the bracket layers. They have to be added manually or by scripting. Workflow would be faster and would take less bookkeeping if bracket layers would be interpolated automatically.

I did it like this. If I reinterpolate on Glyphs2, I get the expected intermediate weight. If I open the file in Glyphs3 and reinterpolate, the result is identical to the bold master.

Screenshot 2021-08-26 at 10.12.28

Thanks for your explanation, but this is a brace layer, not a bracket layer, isn’t it?

Is this screenshot from Glyphs 2 or 3

From Glyphs 3

Then the brace layer is not set up correctly. Right click it and select ‘Intermediate’ and add the coordinate in the dialog.

1 Like

Dear Georg, this week we will again run into this problem. The range of superior letters is to be edited to meet the requirements of the intermediate Light Master. Several superiors have to be re-interpolated and have bracket layers … we would really appreciate if you can fix this.

great that’s the thing that was missing, thanks!