Glyphs 2 file brace layer name/value keeps getting reset to empty or {} in Glyphs 3

Hi!
When using a Glyphs 2 file in Glyphs 3 my brace layer keeps getting reset to no value. For example here, it is set as {0, 150}, and appear as {}.

I can edit it but if I save and reopen the file it will be removed again.
image

[Update]

To be more precise when converting a Glyphs 3 file to Glyphs 2, the brace layer name is erased and replace by empty. Once I try to edit it, save it and restart the document it returns {}.

image

[Update 2]

For a reason I ignore, only the letters are touched.
The numbers using brace are not emptied or turned to {}

image

can you send me a glyphs 3 file that looses the brace layer when saving it as G2?

1 Like

I already sent you few emails with more details and the files to the support email.
I sent you another one with a Glyphs 3 file.

I got your file but it is working fine for me. What exactly did you do to trigger this?

Weird!
I made a video to show you exactly what I do. I sent it to your mail.

Font Info -> Glyphs file version -> Change from 3 to 2 -> Save as
Then I open either in Glyphs 2 or Glyphs 3.

Just so you know I removed the plugin folder before doing the manipulation in the video.

In the case you couldn’t reproduce the same bug, the only thing I can think of that could differ from your Glyph version to mine is Python.
I’m using Python 3.9.1.

Thanks for your help. I found the problem and fixed it.

1 Like

Thanks, I did the update, the brace works now!