Glyphs 2 installation crash on Ventura

I’ve tried to install latest Glyphs2 on Ventura 13.3 MacOS, but icon is bouncing in dock panel for a long time and nothing happens. Is it a bug of my device or the latest app build don’t support this OS right now?

Please read this: Glyphs 2 on Monterey | Glyphs

Thanks! Removing existing python and homebrew libraries, and reinstalling of required versions, helped me to run Glyphs2 with plugins.
Only Red Arrows plugin still doesn’t work.

We are trying but can’t guarantee that all plugins work in all versions of macOS in old versions of Glyphs.

Do you get an error message?

I see this error in macro panel on startup Glyphs2 with installed Red Arrows

Unfortunately, I can’t fix that easily right now.

1 Like

In Glyphs 2, you can try uninstalling and reinstalling the modules via Glyphs > Preferences > Addons > Modules > Install Modules. But it probably will not fix this issue. The plug-in would need to be changed.

1 Like

As the developer of RedArrow, I must admit I don’t have a working copy of Glyphs 2 on my main computer anymore, so I forget to check if I introduce incompatibilities when I update the plugin. Sorry.

You could try to install an older version of the plugin. The latest RedArrow release to support Python 2/Glyphs 2 is v2.0.5 as far as I can see. Download the and install from there.

1 Like

It’s working! Thank you :clap: