Glyphs 2 stops working

I tried to open a file I worked on yesterday with no problems,
and got pop up:

The document … could not be opened.
This beta version of Glyphs is more than 30 days old.
Please check for an update”

Well, I did. And got the new one:

Update Error!
An error occurred in retrieving update information.
Please try again”

Is it just me?

Drag the .glyphsLicense file on the app icon again.

Solved, thank you.

I got the same error today after 30 days working with the 2.0 beta. Only, it won’t solve after opening the lincense key.

You need to check for updates to get a new version.

Having a problem with the .glyphsLicense file as 2.0.1 (744) test expires 17th May 2015.
Cannot get it registered by dragging the license on the app icon.



You need a new license file for Glyphs 2.

To Georg,

I already have a new license which was installed on my system but it says I need to register it again are there any issues running OSX 10.10.3 as the license not validate correctly.



Does your license file have a .glyphs2license suffix? Note the digit two.

I had not double clicked the License file inside the downloads area of my web browser, but was trying to drag the text file license details sent from FastSpring onto the Glyphs application but It’s working now.