Glyphs 3 cannot open exported variable font + broken kerning in variable export

Hi, I exported single axis variable font in Glyphs 3 (last official release as well as the last cutting edge version) - I have a couple of problems with it, I will list them in one post, as the cause may be common.

The exported variable file cannot be opened in the same Glyphs 3 it was a exported minute ago, but it opens in Glyphs 2.

Here is the error message I get in Glyphs 3:

The document “KprGX.ttf” could not be opened. Error while reading the document: …
(*** -[__NSArrayM objectAtIndexedSubscript:]: index 14 beyond bounds [0 … 12])

I can open exported file in Axis-Praxis, but the kerning is broken - it seems that (after examining in FontLab) all the kerning was copied from thin master to bold one - for all glyphs.
(it also seems that the Zero Kerner plugin does not work in Glyphs 3 for now?)

Another problem is a strange error in Sketch app - the font loads, but after changing the weight to anything other than regular, the font changes to a system font.

Thanks for your assistance!

That should be fixed in the upcoming update. You can try the latest Cutting edge version (version 3.0.2-3055). If you still see the problem, could you send me the .ttf file?

Thanks for the answer.

I have just updated to 3.0.2 (3058) and exported again (previously I used 3.0.2-3055) Unfortunately the same problems persist in the newest version… never happened to me in Glyphs 2. What would be the best way to send you the .ttf file?

Please send me the .ttf file, then. As a message in the forum or to support at this domain.

Hi Georg, I have just updated to the latest version and the kerning works fine! Thanks a lot for your fast action!

All best,
Roch

One more thing - the alternate layers stopped working in the newest update. They did not work at the beginning, then after an update some weeks ago it started to work fine. The newest update fixed the kerning issue I wrote about, but again the alternate layers do not work in the variable exports.

Strange - kerning works almost perfect, but right kerning of uppercase A does not work for bold weight - everything is too close. For .otf files everything is fine from what I tested.

What do you mean by " alternate layers do not work"? Do you have a sample file?

When I set alternate glyph shape for bolder weights (like dollar, cent and lowercase t in my font) it does not change in the variable exported file - I used the alternate layer type for it. It worked one or two versions back. I am sending you the file exported in 3.0.3 (3061).

Something strange happens with kerning that I cannot understand - it changes depending on the amount of glyphs included in the export. In the file that I will send to you dot with dot kerning is broken and strangely A kerning seems to work fine…

I see. I’ve fixed it.

Thank you! Shall I understand it will be in the next cutting edge update?

Just installed the newest version - alternative layers work fine now, however the problem with kerning in bold weight persists.

I have the same kerning issue - interestingly it works on Romans (including rvrn feature) and not on the italics

Any progress on this? I have the same issue with capital A (incorrect kerning on the right side)…
I’m running Glyphs 3.0.3 (3070) on Mojave 10.14.6

Upper part of the image is in Glyphs app, lower part is the exported GX.ttf on the DINAMO website. Same results in Illustrator…

Really? Nothing? :neutral_face:

Sorry.
Could you send me the .otf and the .glyphs file?

Thanks for the file. I fixed it.