Glyphs 3 crashes immediately when I activate Show Master Compatibility

When I reopen the program, SMC is activated. So the program crashing as I activate it is kind of a minor problem as it doesn’t majorly interrupt my workflow. Just something to note.

I’m on Mac OS Monterey and my Glyphs App is completely up to date.

What version do you have exactly? (The four digit number)

Version 3091

I’m doing the free trial on version 3.0.3 (3091) on Big Sur and it crashes constantly :frowning:

Is this normal? Has a recent minor release made it more crashy? It’s very off-putting

Can you try the latest Cutting Edge version, Build 3100?

This has been happening to me too—in both Big Sur and Monterey—using the latest version of Glyphs. I’ve noticed the issue for at least 3 weeks and I’ve reported it in crash logs multiple times. The two things that seem to frequently cause Glyphs to unexpectedly quit are:

  • Turning reporters on and off. Sometimes it works but often it causes a crash.
  • Opening files, especially if one or two are already open. On one of my computers I can’t have more than 2 normal-size font files open at the same time.*

I have run Glyphs in Safe Mode, starting the app while holding down the shift and option keys. Even with plugins disabled in Safe Mode, these crashes are frequent.

I just spoke to another Glyphs user who has been experiencing the same issue of frequent crashes recently. It feels like using RoboFont! :persevere:

  • On that computer, running Big Sur, Glyphs consistently crashes when it uses around 600MB of memory or more. The computer has 16GB, and this has never been an issue before. I’ve also noticed in Activity Monitor that closing documents barely reduces memory usage. If I open 5 font projects, then close 4 of them, Glyphs continues to use almost as much memory as when all 5 were open. Is that expected behavior?

Can you send a crash report and add a note that it is related to this thread and ping here (the UI of the crash manager is not so good).

And @nowell have you tried the latest cutting edge version (v 3.0.4 3100)?

Just did some testing and got it to crash twice within a few minutes. I submitted the crash reports upon reopening Glyphs. Then I updated to build 3100 and it crashed with similar steps within a minute.

I also saved the macOS crash logs as text files, in case you want them. Thanks, @GeorgSeifert.

Found your crash. Thanks.

Can you try without plugins (Cmd+Shift when starting the app)?

@GeorgSeifert I just tried build 3100 in safe mode, and was not able to cause a crash after about 8 minutes. Great! I tried all the things that seemed to previously cause crashes: opening and closing files, using a lot of memory, toggling reporters (only the built-in ones, of course, like show master compatibility), and toggling settings. For what it’s worth, I still noticed that closing documents barely frees up any memory, but that’s probably another issue entirely.

Let me know if this is helpful information, and if you think you’ll be able to get it working reliably with plugins enabled.

That is helpful. Now you could put some plugins back and see if crashes. Then we can narrow it down what plugin is causing it.