Glyphs 3 crashes randomly

… without crash reports to send. Checked /Application/Utilities/, the last log is like below:

dynamic_cast error 2: One or more of the following type_info’s has hidden visibility or is defined in more than one translation unit. They should all have public visibility. N10__cxxabiv116__shim_type_infoE, id, N10__cxxabiv117__pbase_type_infoE.

both 3.0.3 (3091) and 3.0.4 (3104) have this issue on my setting, a MacBook Air M1 with macOS Monterey

Can you try starting Glyphs with the Option and Shift keys pressed. That will disable all external plugins. Those can cause issues like this.
And please send all crash reports through the dialog that comes up when you restart the app. And add a note that refers to this thread.

There is no such dialog whatsoever. The Glyphs 3 window just vanishes. I haven’t install any plugin yet. Anyway, just tried starting with Option and Shift key pressed, problem persists.

The crash reporter dialog should come up when you restart the app.

Sorry to bother, but the said reporter dialog did not come up when I restart. Is there any way I can use to generate the report specificly?

Oh, one suspicious case is that on my computer the ~/Application Support/Library/Glyphs 3 folder didn’t exist in the first place. I’ve created folders like ~/Application Support/Library/Glyphs 3/Repositories manually to install Python runtime, and the installation succeeded.

Where is your Glyphs located?
Which version are you running? Did you make sure you have the latest?

I dragged it into /Applications/ folder, and opened it from there.

Thread 4 Crashed::  Dispatch queue:
0   libsystem_kernel.dylib        	       0x1a07119b8 __pthread_kill + 8
1   libsystem_pthread.dylib       	       0x1a074515c pthread_kill + 288
2   libsystem_c.dylib             	       0x1a0682314 abort + 164
3   Glyphs 3                      	       0x100904f74 0x100734000 + 1904500
4   Glyphs 3                      	       0x10079cd5c 0x100734000 + 429404
5   CoreFoundation                	       0x1a091b3d8 __handleUncaughtException + 676
6   libobjc.A.dylib               	       0x1a05ea194 _objc_terminate() + 132
7   Glyphs 3                      	       0x1007918c8 0x100734000 + 383176
8   libc++abi.dylib               	       0x1a0700ee4 std::__terminate(void (*)()) + 20
9   libc++abi.dylib               	       0x1a0700e80 std::terminate() + 64
10  libdispatch.dylib             	       0x1a0586bc0 _dispatch_client_callout + 40
11  libdispatch.dylib             	       0x1a058a080 _dispatch_continuation_pop + 504
12  libdispatch.dylib             	       0x1a059d1a4 _dispatch_source_invoke + 1356
13  libdispatch.dylib             	       0x1a059831c _dispatch_root_queue_drain + 396
14  libdispatch.dylib             	       0x1a0598b58 _dispatch_worker_thread2 + 164
15  libsystem_pthread.dylib       	       0x1a0741574 _pthread_wqthread + 228
16  libsystem_pthread.dylib       	       0x1a07402c4 start_wqthread + 8

finally got a crash report after restart macOS, but said dialog when restart the app still did not show up. Hope this helps.

Thread 4 crashed with ARM Thread State (64-bit):
    x0: 0x0000000000000000   x1: 0x0000000000000000   x2: 0x0000000000000000   x3: 0x0000000000000000
    x4: 0x0000000000000010   x5: 0x000000011d549520   x6: 0x0000000000000000   x7: 0x0000000000000000
    x8: 0x81e608bb388ce3e7   x9: 0x81e608ba570a53e7  x10: 0x03000001f9422621  x11: 0x04000001f9422621
   x12: 0x0000000000000005  x13: 0x000000011d546390  x14: 0x0000000000000004  x15: 0x00000001f944e9a8
   x16: 0x0000000000000148  x17: 0x00000001fab2b530  x18: 0x0000000000000000  x19: 0x0000000000000006
   x20: 0x000000016f86b000  x21: 0x0000000000016e07  x22: 0x00000001fa084000  x23: 0x000000012880ba00
   x24: 0x000000011d31d2c0  x25: 0x000000011d316090  x26: 0x00000001ea96e1ad  x27: 0x00000001ea96fb25
   x28: 0x00000001a0c2c880   fp: 0x000000016f86a7a0   lr: 0x00000001a074515c
    sp: 0x000000016f86a780   pc: 0x00000001a07119b8 cpsr: 0x40001000
   far: 0xffff80001004000c  esr: 0x56000080  Address size fault

Tried macOS Monterey 12.0.1 and 12.1, both version have this issue.

@GeorgSeifert Is there any way that I can send my crash report privately?

  "cpuType" : "ARM-64",
  "procName" : "Glyphs 3",
  "procPath" : "\/Applications\/Glyphs\/Contents\/MacOS\/Glyphs 3",
  "bundleInfo" : {"CFBundleShortVersionString":"3.0.4","CFBundleVersion":"3108","CFBundleIdentifier":"com.GeorgSeifert.Glyphs3"},
  "storeInfo" : {"deviceIdentifierForVendor":"EA7F0637-3323-53A6-A85C-8E8F51BB95F9","thirdParty":true},
  "parentProc" : "launchd",
  "parentPid" : 1,
  "coalitionName" : "com.GeorgSeifert.Glyphs3",
  "crashReporterKey" : "61B4577D-C81C-9358-99DC-80B93CFDC94E",
  "wakeTime" : 445,
  "sleepWakeUUID" : "FF5EBC40-F10D-465C-80B9-6B73E4811CF5",

In addition to the above.

  1. Computer put into sleep [pull down menu]. Glyphs is running with no windows open.
  2. Glyphs does not wake up (menu shows “Force Quit”)
  3. Restart computer and no crash dialogue appears

This has occurred a few times. Each time on sleep.

tried the suggested shift + option restart. no crash dialogue appeared.

Glyphs = 3.0.4 (3108)**
MacOS = 12.0.1 16GB Memory

Glyphs Plug-in = Trace Plug-in Georg Seifert developer (installed but never used)
Glyphs Scripts = Mekkablue Rainer Scheichelbauer with schriftgestalt scripts
Glyphs Modules = FontTools, Python, RoboFab, Vanilla.

 I've never run scripts or plug-ins. 

Thank you

All installed plugins are loaded regardless if they where every used. If there is a problem during loading the plugin, it will do its harm anyway.

Can you try to make a spindump when the app hangs (after waking the mac up)? The can be done in the Activity Monitor app in the toolbar button with a circle and three dots. The resulting file usually is quite big so send it by email.

I haven’t got any plugins installed. The ~/Library/Application Support/Glyphs 3 folder is empty. I’ve selected the latest crash report and sent it to the email mentioned at the contact page. Look forward to future inquiries.

Two questions:

  1. Do the crashes also occur in a new user? Create one in System Preferences, switch to the user, run Glyphs. If the app is stable in the other user, we know it is caused by a setting in your user.
  2. Are you running any kind of antivirus, maintenance or system optimisation tools? MacCleaner, Avast or the like?
  1. Problem is gone in new user! Finally we can narrow down the problem a bit.
  2. I’ve deleted all antivirus softwares that I have got when migrating from another Mac. I’ll try removing more to root the cause.
1 Like

I think I’ve solved the problem! It is caused by wrong permission settings of ~/Library/Application Support. The one of the newly created user is 0700 and belongs to the account itself. But mine was 0755 but belonged to admin:root. I’ve reset the ownership then the crash report dialog finally shows up. And the app doesn’t quit ever since.

I believe the root cause is that Glyphs 3 writes stuff to this folder to store user data but failed because of the wrong permission setting (such as failed to create new subfolder).

Anyway, thanks guys!

1 Like

Good to know. Thanks for figuring this out. I’ll see if I can debug this.