Glyphs 3 crashes while adding instances

Hello there.
It crashes after creating instances, after having imported two masters from open Glyphs files. Can’t reopen anymore neither the file nor the app!
I re-downloaded it to start from scratch again but the problem persists.

(I’m regular user of Glyphs 2. Never had this trouble.)

MacOs 10.12.6
Glyphs latest version: 302 (I think?)
Several (usual) plugins were installed while using for the fist time (yesterday).

That is fixed in the latest cutting edge version.

1 Like

Thanks! where shall I download it from?

You can activate it in Preferences > Updates.


No, I can even start the app…


Can you start without loading plugins by holding down the Option and Shift key? Then open the plugin manager to update all plugins to the latest version. Then you should be able to start the app normally.

Already tried that, it does not open.
Also erased ~/Library/Preferences/com.GeorgSeifert.Glyphs3.plist
and it still doesn’t open (the app, not the file, which must be corrupted by now).
I have Glyphs 2 with many plugins installed and all… Should I also uninstall all of that? Or Glyphs 3 should work independently?

I think I got it, I hadn’t seen that in here
~/Library/Autosave Information/
the plist file must be erased as well.
Now the app opens, though I get an error message when upgrading to cutting edge version.

Now it seems I could.

In case it help.

Captura de pantalla 2021-03-05 a la(s) 19.09.03

You can remove and reinstall all of them. The problem that lead to the crash is fixed.