Glyphs 3 - Entry and Exit anchors are messed and fonts not updating in InDesign


I recently ported my font to G3 (latest cutting edge release on latest MacOS).

I noticed that the entry and exit anchors are not working and are being ignored by Indesign CC (latest version).


I’m exporting the font to Adobe font folder but the changes are not reflected in InDesign as it used to. I need to restart InDesign after every export.

Also, this strange warning keeps showing:

I noticed that ‘entry’ marks are hollow circles, unlike ‘exit’ anchors, which are solid circles.
Is that a bug or intended change?


Can you send me the .glyphs file? I just tried it and it works fine for me.

Looks like you have some special, non-ASCII line break character there. Can you copy the lines around the affected line and paste it here?

If you’re switching between different keyword languages while working, it might explain why it pops up only at certain lines and not on each line break.

.glyphs file mailed.


The invalid character was “U+2028”.



Thanks, how do i get it working?

Just tried to update G3, no updates available yet.


I need to upload a new version. A few things to test until I can do that.