Glyphs 3 Error: nil argument

Hi there,

I get this error message when I try to open some .otf files in Glyphs 3:

Error reading the document.
(-[__NSCFString appendString:]: nil argument)

The problem does not occur in Glyphs 2.

I think something needs to be changed in the original Glyphs file.
Because exporting a new .otf with Glyphs 3 doesn’t help and some other files are fine.

Thanks in advance for any help!

Can you try the latest cutting edge version. You can activate it in Preferences > Updates.

Thank you very much! 3.0.2 fixed it.


The document could not be opened. Error while reading the document
(-[__NSCFString appendString:]: nil argument)

I am currently running 3.0.2 and I got the same error trying to export trial fonts, with the following custom parameters:

— Remove Prefixes
— Remove Classes
— Remove Features
— Keep Glyphs

Thanks for the help!

Can try the latest cutting edge version (activate it in Preferences > Updates)?

I misread the first reply. It works great now! Thanks