Glyphs 3 export hinting issue

I cant export from Glyphs 3, I´m getting the massage:
“There was a problem autohinting the glyph: .notdef”
Clearing the temp files does not resolve the issue. Even if I remove the .nodef glyph, I´m still getting the message.
I try it in 3 different projects, unfortunately the same error massage.

PostScript autohinting? Add a Disable autohinting for glyphs parameter with .notdef in its list.

Yes it is PS hinting. After using Disable autohinting for glyphs parameter with .notdef the same error message comes for A:

After disabling autohinting for A, it comes for Aacute.
I also reinstalled Glyphs 3 but did not work too.

Maybe something is wrong with the stem and zones settings? Can you send me that .glyphs file?

Thanks Georg! File is in your mailbox.

All stems had a scope filter (Letter), and there were too many conflicting stems for PS hinting. My advice:

  • In each master, add a TTFStems parameter, and each time import the PS stems through the gear menu.
  • In Font Info > Masters > Stems, remove all stems except one or two H stems, and one or two V stems. Remove their scope filter through their gear menu.
  • Remove the Alignment Zones parameter from the stems. Consider adding the missing zones to Font Info > Masters > Metrics.

That fixed the hinting issue for me. Then a different remove overlap issue occurred, which, for the time being, I could only resolve by not exporting the offending glyph. (@GeorgSeifert: I will isolate the glyph in a separate file and open a git issue with it.)

UPDATE @lettersoup: In case you run into the issue, you can temporarily make Remove Overlap work for the glyph again if you move the bottommost (green) smooth node by 1 unit.

1 Like

Many thanks Rainer!
This file is a project that I made in Glyphs Version 2.6.5 (1342).
It is strange that Glyphs 3 opens the stems with a scope filter (I never add one, I´m not even sure if that was possible in Glyphs 2 for the stems). It might be possible that it is a portation issue,
Glyphs 3 puts also the additional Alignment Zones automatically as a custom parameter. They were set in the AZ field in Glyphs 2.

Bildschirmfoto 2020-11-21 um 19.39.51

Maybe @GeorgSeifert could fix that with the next update.

It would be grate if you can update the hinting tutorial and advice how “should” the custom naming of the alignment zones look like.