Glyphs 3 Python Install

I’ve tried all the steps to install Python and start writing in the Macro Panel, but it does not seem to respond when I try to run a print line.

For context, I am running Glyphs 3 on a macOS Monterey 12.0.1. Python 3.11.1 is installed and appears when I check for the version on this Mac.

In Glyphs under Preferences, I do see a Python version 3.9.1 (Glyphs) that is selected and offers no other options.

I did see some advice about installing Homebrew, which I tried before doing the reinstall.

At this point, I’m not sure what I need to do, as I have restarted glyphs and my Mac multiple times to see if anything will work.

Please help!

Perhaps something went wrong with the installation of Python.

  1. Uninstall Python by going to WindowPlugin ManagerModules and clicking Remove next to Python.
  2. Verify that Python has been uninstalled completely by choosing ScriptOpen Scripts Folder and looking into the Repositories folder next to the Scripts folder. These should not be a folder named GlyphsPythonPlugin inside Repositories. If there is, manually delete it.
  3. Go back to the Plugin Manager and install Python again. Wait for the installation to complete, then relaunch Glyphs. In the preferences, make sure the Python version ending in “(Glyphs)” is selected, otherwise select it and relaunch Glyphs again.

Thank you! I’ve followed all steps and this still doesn’t seem to resolve the issue. I have also tried using the ‘Clear’ button. When I click it, the code does not clear. So, something is not allowing it to run or clear. Any other suggestions would be helpful.

Could you post a screenshot of your Macro panel?

Ok here’s a screenshot of what happens when I try to Run or Clear. There’s nothing prompting me to do anything else.

If I type a line that is incomplete, there is a warning that pops up, as it should:

In the first screenshot, what happens when you click Run?

Nothing, it appears just like that, as if I didn’t hit Run at all.

Ah, you might have the Use system console for script output checkbox checked in the Addons preferences. Uncheck it and try running again.

Yes! There was a slight delay but it works! Thank you!

@FlorianPircher – Isn’t a restart necessary between steps 2 and 3?

I don’t think so, but do let me know if otherwise it does not work for you.

Hi there,
So for the last few months, I have been able to use the macro window without any issues. I tried to work through another script today, and nothing appeared in the Macro Window when I tried to run the script. I followed the steps again to reinstall Python as I had done when I first had trouble with installation. I also unchecked the box in Addons as well. This time, no success and I just get a message about how no compatible version of Python is installed. I’m just curious if this is a bug with the latest update, as it was working perfectly before.

Uninstall and reinstall in Plug-in Manager. Does this have success?

I just updated the python version and it needed some time to settle. Removing and re-installing should fix it.

Hi there,

Thank you! I just tried reinstalling in the Plug-in Manager one more time and it works!