Glyphs 3 won't start after install Python 3.9

Dear lovely Glyphs Team.

I installed Python 3.9 because I had problems to run certain plugins and thought the older version of Python could maybe the problem. After I installed Python 3.9 Glyphs3 was more or less broke. Every time I try to start it, it immediately closes itself.

I already uninstalled Python 3.9 but the problem is still the same.

Do you have any idea how I can fix this mess?

Thank you a lot in advance for your respond!

I’m also having a similar issue. Glyphs wouldn’t download python so I did it manually at 3.9 and now I can’t get glyphs to change the version to make it work in the addons setting.

Uploading an image to assist :slight_smile:

I uninstalled every folder from Python3.9 and installed Python3.8. Now Glyphs is running again but I’m not able to install any plugins. Does someone know a way to fix that?

Got the fix! Head to the plugin manager - then modules - install Python from the modules and restart. Then you can change your python.

If that fails you can also hold Option + Shift when starting glyphs. I removed my plugins before doing this. Hope it helps. @fabianmaierbode

1 Like

@Will_Paterson Thank you! Did you update Python to Python3.9?

No, I just used the Glyphs Python :slight_smile:

Okay, I did this also. But I still get this message if I’d like to install any kind of plugin:

Make sure to change the Python Version

1 Like

Okay, that’s weird because I only have 3.8.2 to select :man_shrugging:t4:

@fabianmaierbode Do you happen to have a new Apple Silicon mac?

No, I’ve a 3 year old MacBook Pro. Do I need to download the latest Python version by myself? At least now the program itself is running again :slight_smile:
@GeorgSeifert Is this GaugeTool running anyway on Glyphs3?