Glyphs App 2.6.5 is crashing

Hi, I am using Glyphs App 2.6.5. It started crashing constantly. I checked all the crash topics one forum. Initially Command + Shift worked, but that I also not helping now. Attching crash report screen shot.

I am in middle of a project, so I can’t upgrade to Glyph3. Need help!

It looks like the Master Selector plug-in is causing the crash. You can see this below the headline for the thread that crashed (in this case ‘Thread 0’).

Hold down Option and Shift to deactivate plug-ins.

Thanks. I tried Option. + Shift. Still not opening the app. I removed all the plugins from Plugin folder.

Can you post the crash report again (but copy paste the top part of the crash-text instead of a screenshot).

Now the trash report is also not popping. The app icon jump for the Dock and that’s it. Nothing happening. I just have that screenshot. Should I uninstall the current 2.6.5 versional install Glyph 2 again?

You can find Crash Reports in Console.app (in /Applications/Utilities)

Can you try opening the app in a different user?

Process: Glyphs [6766]
Path: /Applications/Glyphs.app/Contents/MacOS/Glyphs
Identifier: com.GeorgSeifert.Glyphs2
Version: 2.6.5 (1342)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Glyphs [6766]
User ID: 501

Date/Time: 2021-03-29 15:17:25.652 +0530
OS Version: Mac OS X 10.14.5 (18F132)
Report Version: 12
Bridge OS Version: 4.6 (17P6610)
Anonymous UUID: 22BDA03B-A687-329F-30F0-85856F766145

Sleep/Wake UUID: 110A0CA9-092D-4D1E-916D-AA05031FC3B5

Time Awake Since Boot: 16000 seconds
Time Since Wake: 5900 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [6766]

VM Regions Near 0:

__TEXT 000000010b96f000-000000010bab7000 [ 1312K] r-x/r-x SM=COW /Applications/Glyphs.app/Contents/MacOS/Glyphs

I tried switching user, but app is not opening.

  • Try replacing the app with a fresh download from the Get Glyphs page.
  • Then update to the latest beta. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.
  • Any antivirus, helper, cleaner or system maintenance tools running? Delete them. More details in the “Cannot Download” tutorial.

This crash is from two days ago, so most likely caused by a plugin.

Get Glyph page has Glyph 3 and Glyph Mini. I need Glyph 2.
No antivirus, helper, cleaner or system maintenance tools are installed.

We do not sell Glyphs 2 licenses anymore, but the download link is listed on the Get Glyphs page:

image

Thanks. The Glyphs is working now. These inputs may help me in future.
May thanks for quick response. :slight_smile:

Same problem.
A lot of plugins start crashing with 2.6.5 and 2.6.6:
CaseChange, Suffixes, Show Kerning Groups, Show Siblings

Can you make sure to get the latest version of the plugins. Remove and re-install them in the Plugin Manager.

2.6.7 + reinstall plugins and modules, everything is fine now.