Glyphs beta won't open

Hi guys

I’ve just tried to open glyphs and this message pops up.
Can’t get to the menu to update it.
Can you help?

Redownload the latest stable version from and update.

Resolved! Thanks

Hi Mekkablue,
I have the same problem, do I complete the full purchase form to re-install my licensed copy of Glyphs?
Thanks, Michiel.

The license info in independent of the app bundle. You just need to download the new version. No need to apply the license file or even repurchase.

Thank you Georg. When I follow the instructions I still get the message; this beta version is more than 30 days old.

This is what I see.

and also this one;

Have you tried moving Glyphs to the app folder in your HD?

Yes, Glyphs is in the applications folder.

I can open Glyphs from the Dock and open a font.

When any of the two messages happen, redownload from and update again.

If you are using the Cutting Edge Betas, I strongly recommend the option Glyphs > Preferences > Updates > Automatically check for updates. Then you will be reminded in time to update your beta.

When I got the same message as you did, updating Glyphs from the site worked for me.
I wonder if you delete your version of glyphs and do a clean install, it might work.
Not an expert, just trying to help. :slight_smile:

How do I update Glyphs from the site without buying another copy?

The ‘readonly’ message happens mostly if the app is in the downloads folder. You might have several versions?

Hi Georg, I think I just did it right, all is well, thank you for your help.
Fröhliche Weinachten und ein Gutes Neujahr.